通达信支撑与压力的神级主图指标公式

  • A+
  • 局部低点预选A:=BACKSET(LLV(L,5)REF(HHV(H,4),1),4);

  • 局部高点预选B:=BACKSET(局部高点预选A=0 AND REF(局部高点预选A,1)=1,2);

  • 局部高点预选C:=IF(局部高点预选B=1 AND REF(局部高点预选B,1)=0,1,0);

  • 缺口判断:=IF(L>REF(H,1),1,IF(HREF(距前低天,1) AND LLV(L,距前高天+1)=4 OR LLV(缺口判断,距前高天)=-1 OR LLV(L,距前低天+2)REF(小值周期,距前低天+1) AND 大值周期>REF(小值周期,距前低天) AND 大值周期>REF(大值周期,距前高天),1,0);

  • 高保留A:=IF(局部高点预选C=1 AND REF(距前低天,1)>REF(距前高天,1) AND HHV(H,距前低天+1)>REF(HHV(H,距前低天+1),1),1,0);

  • 高保留B:=IF(局部高点预选C=1 AND REF(距前低天,1)=4 OR HHV(缺口判断,距前低天)=1),1,0);

  • 高保留:=IF((高保留A=1 OR 高保留B=1 OR 判断=1) AND H>REF(L,距前低天+1),1,0);

  • 预判A:=IF((距前高天REF(大值周期,距前高天+1) AND 小值周期>REF(大值周期,距前高天) AND 小值周期>REF(小值周期,距前低天),-1,0);

  • 低保留A:=IF(局部低点预选C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)=4 OR LLV(缺口判断,距前高天)=-1 OR 判断A=-1),-1,0);

  • 低保留:=IF((低保留A=-1 OR 低保留B=-1) AND LREF(小值周期,距前低天A+1) AND 大值周期>REF(小值周期,距前低天A) AND 大值周期>REF(大值周期,距前高天A),1,0);

  • 高保留XA:=IF(局部高点预选C=1 AND REF(距前低天A,1)>REF(距前高天A,1) AND HHV(H,距前低天A+1)>REF(HHV(H,距前低天A+1),1),1,0);

  • 高保留XB:=IF(局部高点预选C=1 AND REF(距前低天A,1)=4 OR HHV(缺口判断,距前低天A)=1),1,0);

  • 高保留X:=IF((高保留XA=1 OR 高保留XB=1 OR 判断X=1) AND H>REF(L,距前低天A+1),1,0);

  • 预判XA:=IF((距前高天AREF(大值周期,距前高天A+1) AND 小值周期>REF(大值周期,距前高天A) AND 小值周期>REF(小值周期,距前低天A),-1,0);

  • 低保留XA:=IF(局部低点预选C=-1 AND REF(距前高天A,1)>REF(距前低天A,1) AND LLV(L,距前高天A+1)=4 OR LLV(缺口判断,距前高天A)=-1 OR 判断XA=-1),-1,0);

  • 低保留X:=IF((低保留XA=-1 OR 低保留XB=-1) AND LREF(小值周期,距前低天YA+1) AND 大值周期>REF(小值周期,距前低天YA) AND 大值周期>REF(大值周期,距前高天YA),1,0);

  • 高保留YXA:=IF(局部高点预选C=1 AND REF(距前低天YA,1)>REF(距前高天YA,1) AND HHV(H,距前低天YA+1)>REF(HHV(H,距前低天YA+1),1),1,0);

  • 高保留YXB:=IF(局部高点预选C=1 AND REF(距前低天YA,1)=4 OR HHV(缺口判断,距前低天YA)=1),1,0);

  • 高保留YX:=IF((高保留YXA=1 OR 高保留YXB=1 OR 判断YX=1) AND H>REF(L,距前低天YA+1),1,0);

  • 预判YXA:=IF((距前高天YAREF(大值周期,距前高天YA+1) AND 小值周期>REF(大值周期,距前高天YA) AND 小值周期>REF(小值周期,距前低天YA),-1,0);

  • 低保留YXA:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)>REF(距前低天YA,1) AND LLV(L,距前高天YA+1)=4 OR LLV(缺口判断,距前高天YA)=-1 OR 判断YXA=-1),-1,0);

  • 低保留YX:=IF((低保留YXA=-1 OR 低保留YXB=-1) AND LREF(H,REF(距前高天YA,1)+2),1,IF(高保留YX=1 AND 低保留YX=-1 AND LXA45 AND CXA63  AND CXB63  AND CXB45  AND COPEN,VAR11*(HIGH-LOW),IF(CLOSEOPEN,VAR11*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE4,NODRAW;

  • BB:=净买0,C,O,3,0),COLORRED;

  • STICKLINE(净买9,H,O,3,0),COLORWHITE;

    weinxin
    我的微信
    关注我了解更多内容