通达信私募内部专用主图指标公式

  • A+
  • DRAWKLINE(H,O,L,C);

  • ZKP:=IF(C>REF(C,1),REF(C,1),DRAWNULL);

  • ZSP:=IF(C>REF(C,1),C,DRAWNULL);

  • DKP:=IF(CREF(C,1),ZKP,ZSP,3.05,0),COLOR000099;

  • STICKLINE(C>REF(C,1),ZKP,ZSP,2.2,0),COLOR0000CC;

  • STICKLINE(C>REF(C,1),ZKP,ZSP,1.5,0),COLOR0000FF;

  • STICKLINE(C>REF(C,1),ZKP,ZSP,0.5,0),COLORCC66FF;

  • STICKLINE(V/REF(V,1)>2 AND CLOSE>=OPEN,ZKP,ZSP,1,0),COLORYELLOW;

  • VAR111:=ZIG(3,13);

  • STICKLINE((REF(VAR111,2) REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));

  • VAR02:=(REF(VAR01,1) AND CLOSE=REF(CLOSE,2));

  • VAR03:=(REF(VAR02,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));

  • VAR05:=(REF(VAR04,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));

  • VAR07:=(REF(VAR06,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));

  • VAR09:=(REF(VAR08,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));

  • VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));

  • VARD:=(CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));

  • VAR010:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));

  • VAR012:=(REF(VAR011,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));

  • VAR014:=(REF(VAR013,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));

  • VAR016:=(REF(VAR015,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));

  • VAR018:=(REF(VAR017,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE30 AND MA5>REF(MA5,1), MA5,DRAWNULL),LINETHICK3,COLORRED;

  • BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;

  • IF(BB5REF((MA20-MA30),1) AND MA20>REF(MA20,1) AND MA30>REF(MA30,1);

  • VAR2:=(MA30-MA20)30 AND BB10>45 AND CROSS(BB5,60),10);

  • 加仓:=FILTER(COUNT(CROSS(BB5,30),5)>=1 AND MA5>REF(MA5,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA10>REF(MA10,1)

  • AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1),10);

  • 清仓:=FILTER(COUNT(CROSS(30,BB5),5)>=1 AND (C>MA30 OR O>MA30) AND MA5REF(MA10,1) ;

  • 减仓:=FILTER(JC,10);

  • MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA5>REF(MA5,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));

  • 买%:=买/AMOUNT*100;

  • 流入:=AMOUNT*买%/10000000000;

  • 流出:=AMOUNT/100000000-流入;

  • 净流:=(流入-流出);

  • 总额3:=SUM(AMOUNT,3);

  • 流入3:=SUM(流入,3);

  • 流出3:=SUM(流出,3);

  • 净流3:=SUM(流入-流出,3);

  • 总额5:=SUM(AMOUNT,5);

  • 流入5:=SUM(流入,5);

  • 流出5:=SUM(流出,5);

  • 净流5:=SUM(流入-流出,5);

  • 总额10:=SUM(AMOUNT,10);

  • 流入10:=SUM(流入,10);

  • 流出10:=SUM(流出,10);

  • 净流10:=SUM(流入-流出,10);

  • 画:=CONST(FINDHIGH(总额10,0,190,1));

  • DRAWTEXT_FIX(1,0.00,0,0,'所属行业:')COLOR00FFFF;

  • DRAWTEXT_FIX(1,0.06,0,0,HYBLOCK)COLOR00FFFF;

  • DRAWTEXT_FIX(1,0.14,0,0,'所属地区:')COLOR00FFFF;

  • DRAWTEXT_FIX(1,0.20,0,0,DYBLOCK)COLOR00FFFF;

  • DRAWTEXT_FIX(1,0.30,0.00,0,'主题投资:')COLOR00FFFF;

  • DRAWTEXT_FIX(1,0.36,0.00,0,EXTERNSTR(0,2))COLOR00FFFF;

  • DRAWTEXT_FIX(1,0.00,0.05,0,'主营业务:')COLOR00FFFF;

  • DRAWTEXT_FIX(1,0.06,0.05,0,EXTERNSTR(0,3))COLOR00FFFF;

  • DRAWTEXT_FIX(1,0.00,0.10,0,'解禁日期:')COLOR00FFFF;

  • DRAWTEXT_FIX(1,0.06,0.10,0,EXTERNSTR(0,4))COLOR00FFFF;

  • DRAWTEXT_FIX(1,0.00,0.15,0,'莸利比例:'),COLORYELLOW;

  • DRAWNUMBER_FIX(1,0.06,0.15,0,CONST(WINNER(C )*100)),COLOR0080FF;

  • DRAWTEXT_FIX(1,0.12,0.15,0,'动态PE:'),COLORYELLOW;

  • DRAWNUMBER_FIX(1,0.17,0.15,0,CONST(DYNAINFO(39))),COLOR0080FF;

  • DRAWTEXT_FIX(1,0.22,0.15,0,'市值:'),COLORYELLOW;

  • DRAWNUMBER_FIX(1,0.26,0.15,0,FINANCE(40)/100000000),COLOR0080FF;

  • DRAWTEXT_FIX  (1,0.31,0.15,0,'公积金(股):'),COLORYELLOW;

  • DRAWNUMBER_FIX(1,0.38,0.15,0,FINANCE(18)),COLOR0080FF;

  • DRAWTEXT_FIX  (1,0.43,0.15,0,'收益:'),COLORYELLOW;

  • DRAWNUMBER_FIX(1,0.47,0.15,0,FINANCE(33)),COLOR0080FF;

  • DRAWTEXT_FIX(1,0.00,0.19,0,'净流入(亿):'),COLORYELLOW;

  • DRAWTEXT_FIX(1,0.06,0.19,0,'1日'),COLORYELLOW;

  • DRAWTEXT_FIX(1,0.12,0.19,0,'3日'),COLORYELLOW;

  • DRAWTEXT_FIX(1,0.18,0.19,0,'5日'),COLORYELLOW;

  • DRAWTEXT_FIX(1,0.24,0.19,0,'10日'),COLORYELLOW;

  • DRAWNUMBER_FIX(1,0.08,0.19,0,CONST((净流))),COLOR0080FF;

  • DRAWNUMBER_FIX(1,0.14,0.19,0,CONST((净流3))),COLOR0080FF;

  • DRAWNUMBER_FIX(1,0.20,0.19,0,CONST((净流5))),COLOR0080FF;

  • DRAWNUMBER_FIX(1,0.265,0.19,0,CONST((净流10))),COLOR0080FF;

  • DRAWTEXT_FIX(1,0.00,0.23,0,'愚民导向:'),COLOR00FFFF;

  • DRAWTEXT_FIX(1,0.06,0.23,0,EXTERNSTR(0,5)),COLOR00FFFF;

  • DRAWRECTREL(0,500,147,999.4,IF(120,RGB(10,0,0),0));

  • 超B:=L2_AMO(0,2)/10000.0;

  • 大B:=L2_AMO(1,2)/10000.0;

  • 中B:=L2_AMO(2,2)/10000.0;

  • 小B:=L2_AMO(3,2)/10000.0;

  • 超S:=L2_AMO(0,3)/10000.0;

  • 大S:=L2_AMO(1,3)/10000.0;

  • 中S:=L2_AMO(2,3)/10000.0;

  • 小S:=L2_AMO(3,3)/10000.0;

  • TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);

  • 大宗进:=(超B)+(大B),NODRAW;

  • 大宗出:=(超S)+(大S),NODRAW;

  • 非大宗进:=(中B)+(小B),NODRAW;

  • 非大宗出:=(中S)+(小S),NODRAW;

  • 大宗进限制:=IF((超B+大B)=0,0,大宗进);

  • 大宗出限制:=IF((超S+大S)=0,0,大宗出);

  • 非大宗进限制:=IF(中B+小B=0,0,非大宗进);

  • 非大宗出限制:=IF(中S+小S=0,0,非大宗出);

  • 主力净流入:=(超B+大B)-(超S+大S),COLORRED,NODRAW;

  • 散户净流入:=(中B+小B)-(中S+小S),COLORRED,NODRAW;

  • 净流入:=(超B+大B+中B+小B)-(超S+大S+中S+小S),COLORRED,NODRAW;

  • 大单流入:=(超B+大B)/(超B+大B+超S+大S)*100,NODRAW;

  • 大单流入限制:=IF((超B+大B+超S+大S)=0,0,大单流入);

  • 大单流出比:=(超S+大S)/(超B+大B+超S+大S)*100,NODRAW;

  • 大单流出限制:=IF((超B+大B+超S+大S)=0,0,大单流出比);

  • 总流入比:=(超B+大B+中B+小B)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW;

  • 总流出比:=(超S+大S+中S+小S)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW;

  • 成交总量:=(超B+大B+中B+小B+超S+大S+中S+小S),NODRAW;

  • 机构参与度:=(超B+超S+大B+大S)/成交总量*100,COLORYELLOW,NODRAW;

  • 大单强度:=(超B+大B-超S-大S)/成交总量*100,COLORYELLOW,NODRAW;

  • 大单强度限制:=IF(大单强度=0,-100,大单强度);

  • 大单强度比:=IF(大单强度>=0,(大单强度限制+100)/2,100-ABS((大单强度限制-100)/2)),NODRAW;

  • 超单强度:=(超B-超S)/(超B+超S)*100,COLORYELLOW,NODRAW;

  • 超单强度限制:=IF(超单强度=0,-100,超单强度);

  • 超单强度比:=IF(超单强度>0,(超单强度限制+100)/2,IF(超单强度0),RGB(255,0,0),RGB(23,125,255)));

  • DRAWRECTREL(37,CONST(930-(ABS(大宗出)*250/DAZHIV)),72,950,IF(CONST(大宗出>0),RGB(23,125,255),RGB(255,0,0)));

  • DRAWRECTREL(75,CONST(930-(ABS(非大宗进)*250/DAZHIV)),110,950,IF(CONST(非大宗进>0),RGB(255,0,0),RGB(23,125,255)));

  • DRAWRECTREL(112,CONST(930-(ABS(非大宗出)*250/DAZHIV)),147,950,IF(CONST(非大宗出>0),RGB(23,125,255),RGB(255,0,0)));

  • DRAWRECTREL(150,CONST(940-(ABS(净流入)*250/DAZHIV))-20,190,950,IF(CONST(净流入>0),RGB(200,0,0),RGB(0,125,50)));

  • DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0001,0.9,0,STRCAT('',CON2STR(大宗进/1,0))),COLORYELLOW;

  • DRAWTEXT_FIX(CURRBARSCOUNT=1,0.036,0.9,0,STRCAT('',CON2STR(大宗出/1,0))),COLORYELLOW;

  • DRAWTEXT_FIX(CURRBARSCOUNT=1,0.074,0.9,0,STRCAT('',CON2STR(非大宗进/1,0))),COLORYELLOW;

  • DRAWTEXT_FIX(CURRBARSCOUNT=1,0.111,0.9,0,STRCAT('',CON2STR(非大宗出/1,0))),COLORYELLOW;

  • DRAWTEXT_FIX(CURRBARSCOUNT=1,0.150,0.9,0,STRCAT('',CON2STR(净流入/1,0))),COLORYELLOW;

  • DRAWTEXT_FIX(1,0.000,0.99,0,STRCAT(STRCAT('主力 ',CON2STR(主力净流入,0)),'万')),COLORMAGENTA;

  • DRAWTEXT_FIX(1,0.078,0.99,0,STRCAT(STRCAT('散户 ',CON2STR(散户净流入,0)),'万')),COLORCYAN;

  • DRAWTEXT_FIX(CURRBARSCOUNT=1,0.145,0.99,0,'净流入:(万)'),COLORYELLOW;

  • 主力买力度:=LARGEINTRDVOL*1000/VOL;

  • 主力卖力度:=LARGEOUTTRDVOL*1000/VOL;

  • AAD:=CONST(MAX(ABS(主力买力度),ABS(主力卖力度)))*4,NODRAW;

  • DRAWRECTREL(0,515,CONST(ABS(主力买力度)*560/AAD),568,IF(CONST(主力买力度)>0,RGB(255,0,0),RGB(0,50,0)));

  • DRAWRECTREL(0,570,CONST(ABS(主力卖力度)*560/AAD),623,IF(CONST(主力卖力度)>0,RGB(0,50,0),RGB(255,0,0)));

  • DRAWTEXT_FIX(1,0,0.524,0,STRCAT('主买力度:',CON2STR(主力买力度,0))),COLORYELLOW;

  • DRAWTEXT_FIX(1,0,0.576,0,STRCAT('主卖力度:',CON2STR(主力卖力度,0))),COLORYELLOW;

  • {http://jue-ce.com}

  • DDX:=(LARGEINTRDVOL-LARGEOUTTRDVOL)*1000/FINANCE(7);

  • DDY:=IF(TRADENUM>0,(TRADEOUTNUM-TRADEINNUM)*100/TRADENUM,0);

  • DDZ:=IF(TRADENUM>0,(LARGETRDINNUM-LARGETRDOUTNUM)/TRADENUM*100,0);

  • DRAWRECTREL(150,500,192,540,IF(CONST(DDX)>0,RGB(255,0,0),RGB(0,50,0)));

  • DRAWRECTREL(150,545,192,585,IF(CONST(DDY)>0,RGB(255,0,0),RGB(0,50,0)));

  • DRAWRECTREL(150,590,192,630,IF(CONST(DDZ)>0,RGB(255,0,0),RGB(0,50,0)));

  • DRAWTEXT_FIX(1,0.153,0.500,0,STRCAT('DDX:',CON2STR(DDX,1))),COLORYELLOW,COLORWHITE;

  • DRAWTEXT_FIX(1,0.153,0.548,0,STRCAT('DDY:',CON2STR(DDY,1))),COLORYELLOW,COLORWHITE;

  • DRAWTEXT_FIX(1,0.153,0.596,0,STRCAT('DDZ:',CON2STR(DDZ,1))),COLORYELLOW,COLORWHITE;

  • T1:=IF (DDX>0 AND REF(DDX,1)0 AND REF(DDX,1)>0 AND REF(DDX,2)0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)>0 AND REF(DDX,9)0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)>0 AND REF(DDX,9)>0,10,T9);

  • DRAWTEXT_FIX(1,0.190,0.500,0,STRCAT(STRCAT(' ',CON2STR(T,0)),' [天] ')),COLORYELLOW;

  • T11:=IF (DDY>0 AND REF(DDY,1)0 AND REF(DDY,1)>0 AND REF(DDY,2)0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)>0 AND REF(DDY,9)0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)>0 AND REF(DDY,9)>0,10,T91);

  • DRAWTEXT_FIX(1,0.190,0.548,0,STRCAT(STRCAT(' ',CON2STR(TY01,0)),' [天] ')),COLORYELLOW;

  • T1Z:=IF (DDZ>0 AND REF(DDZ,2)0 AND REF(DDZ,1)>0 AND REF(DDZ,2)0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)>0 AND REF(DDZ,9)0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)>0 AND REF(DDZ,9)>0,10,T9Z);

  • DRAWTEXT_FIX(1,0.190,0.596,0,STRCAT(STRCAT(' ',CON2STR(TZ,0)),' [天] ')),COLORYELLOW;

    weinxin
    我的微信
    关注我了解更多内容